Are plugins causing issues with my browser?

Episode 1195 (1:24:36)

Arelia from Riverside, CA

Arelia is having issues with her browser and she thinks it may be due to a plugin she installed. Leo says she's probably right. Plugins like Flash, Shockwave or Java are easily hackable and dangerous if not kept up to date.

Leo recommends using Google Chrome. Chrome has Flash built in and it's always updated. If she likes the browser she's using, then she'll have to get the latest version of Flash from Adobe.