Why can't I update my iPod Touch to iOS 7?

Episode 1022 (1:49:08)

Brandon from Springfield, MO

Brandon has an older iPod Touch and can't update the OS. Leo says that iOS 7 probably isn't compatible for iOS 7. The only iPod Touch that's compatible is the fifth generation touch. That's not really a big deal unless the apps he uses need iOS 7 to run.

Topics: